El extraño caso de Lightroom y el plugin «LogiOptions»

In Lightroom by Carlos A. Oliveras13 Comments

En esta entrada comentaré un error que he estado sufriendo con Lightroom Classic durante meses, y para el que no encontré solución hasta hace unas semanas. Es un error relativamente poco común y, aunque alguien lo sufra, no sé si dará con esta entrada – es un problema un tanto genérico. De hecho, puede tener varias causas, no solo la que describiré aquí. Pero os voy a explicar mi caso particular y lo haré un poco en plan «historieta» para pasar el rato, porque a mí me ha traído de cabeza durante una larga temporada.

Lightroom Classic a cámara lenta

Resulta que ahí por el mes de febrero o marzo, Lightroom Classic (en lo sucesivo diré «Lightroom» a secas) empezó a abrírseme con una lentitud exasperante. Desde luego, Lightroom nunca ha sido el más rápido a este lado del Mississippi, pero este «atasco» al arrancar superaba todas sus cotas de lentitud. De hecho, no solo tardaba hasta medio minuto en abrirse, sino que durante este espacio de tiempo, se «colgaba» dos veces si hacía clic en la ventana del programa (es decir, yo veía la ventana, pero no se podía usar hasta que saliera de su «trance virtual»). Es decir, aparecía un aviso de Windows indicando que el programa no respondía. Al cabo de unos diez segundos volvía a responder, pero continuaba en proceso de carga, y si hacía clic otra vez, se colgaba de nuevo, con lo que era mejor no tocar nada, o el proceso completo podía llegar a tomar un minuto. Vamos, más que estarse abriendo, parecía que durante esa fase el programa se debatía entre la vida y la muerte.

Cada vez que lo abría, Lightroom parecía a punto de romperse.

Como ya he dicho, Lightroom es muy «peculiar»: es habitual que sufra pájaras de todo tipo de sin motivo aparente, y que estos fallos sean puntuales o dejen de ocurrir de un día para otro, así que inicialmente tampoco me preocupé mucho por el tema, confiando en que desaparecería tal como había surgido. Pero pasaron las semanas, y aquello seguía igual. Al cabo de unos dos meses, ya me había acostumbrado a abrir Lightroom y ponerme a mirar el móvil mientras tanto, para tomármelo con paciencia.

Por supuesto, traté de pensar a qué venía aquello – repito una vez más que Lightroom no destaca por su agilidad, pero es cierto que en los últimos años se han introducido algunas mejoras que corrigen atascos que sufría en el pasado. Se me hacía raro un paso atrás tan significativo. Y lo más importante: este problema comenzó a ocurrir sin que hubiera instalado ninguna actualización de Lightroom. Es decir, tenía que haber algún factor externo al programa que lo estuviera causando, pero no tenía ni idea de qué podía ser.

Éramos pocos y parió el error interno

Pasado este tiempo, empezó a ocurrirme otro problema que ya me preocupó más: resulta que cuando borraba una imagen del catálogo, me aparecía este error sobre nosequé de un error interno:

En español vendría a ser algo así como «Se ha producido un error interno: ?:0: se intentó indexar un valor nulo» – aunque no sé si con Lightroom en castellano este error se muestra traducido o no.

Pese al error, la imagen se borraba del catálogo, pero aquí fue donde empecé a preocuparme más, porque me preguntaba si no se me estaría corrompiendo el catálogo o algo por el estilo. Probé a optimizar el catálogo desde «Archivo>Optimizar catálogo…» (en mac supongo que está en «Lightroom>Optimizar catálogo…«), pero el error se seguía produciendo.

Por fin un sospechoso

Pero al menos, ahora tenía algo más específico con lo que hacer una búsqueda, así que me puse a investigar por Internet. Además, ahora estaba más preocupado que antes, pues como decía, estaba con la duda de si algo se me estaba «escacharrando» internamente en el catálogo. Y enseguida llegué a una página donde varios usuarios sugerían que este error suele estar provocado por plugins mal programados o defectuosos en algún aspecto. Esto también me extrañó, porque los únicos plugins que tengo instalados en Lightroom llevan mucho tiempo ahí, y tampoco los había actualizado en todo este tiempo. Así de memoria, me vinieron a la cabeza uno de Nik Software, el de Luminar y el de LR/Instagram, aparte de algunos que trae Lightroom por defecto.

Antes de abrir Lightroom y examinar el apartado de plugins, indagué un poco más por Internet, y leí que un usuario apuntaba a un plugin en particular como el culpable de este error: Logitech Options. ¿¿Logitech Options?? Me quedé a cuadros e intrigado a la vez, y os explico el por qué a continuación.

¿Qué es Logitech Options?

Logitech Options es un programa que se instala para poder gestionar la configuración de ratones Logitech. Bueno, esto no es del todo cierto, porque realmente, Logitech tiene un programa más completo para configurar teclados, ratones y cámaras web de la marca. Pero por algún motivo, el ratón que uso actualmente no funciona con el software estándar de Logitech, y necesita un programa especial llamado así (Logitech Options). Aquí podéis ver cómo luce la aplicación en cuestión:

No es, ni mucho menos, un ratón especial para retoque fotográfico, y por eso me quedé muy extrañado ante la idea de que esta aplicación me estuviera instalando un plugin para Lightroom, y encima sin avisar por ningún lado. No tenía mucho sentido, y por eso me quedé extrañado.

Además, suponiendo que esto fuera cierto, tampoco entendía qué función podía cumplir un plugin para este ratón, aunque por lo que he sabido luego, se ve que pueden crear configuraciones específicas para ciertos programas. Cosa que me sigue pareciendo rara: ¿hace falta un plugin para eso? ¿Y además, para algo tan específico como Lightroom? Con el software de Wacom se puede hacer algo similar, y no necesita plugins ni inventos de esta clase (y eso que, en ese caso, sí es un producto específico para la edición y retoque de imágenes).

Pero bueno, en todo caso, yo estaba prácticamente convencido de no tener instalado dicho plugin, ya que como decía, me parecía improbable que un producto tan genérico como este ratón fuese a colarte un plugin para algo tan concreto como Lightroom.

Ahora bien: decía antes que me quedé intrigado por un motivo. Y es que justamente alrededor de la época en que me empezó a fallar Lightroom, yo había cambiado de ratón. Mi ratón «normal» se había estropeado, y desde entonces estoy usando un pequeño ratón que tengo para usar con el portátil. Y para configurar uno de los botones, instalé el susodicho «Logitech Options«. No podía jurar que el inicio de mis problemas con Lightroom correspondiera exactamente con la instalación de este software, pero desde luego, no andarían muy separados en el tiempo. Por más improbable que me pareciese que esta fuese la explicación, lo cierto es que la coincidencia era sospechosa. Muy, muy sospechosa.

Una visita al panel de plugins

Tan pronto como detecté esa misteriorísima coincidencia temporal entre la instalación de Logitech Options y los problemas con Lightroom, me dirigí al icono del programa para abrirlo. Por supuesto, me lo tomé con calma: como de costumbre, el programa se abrió con una lentitud exasperante, y con el preceptivo doble cuelgue durante todo este proceso.

Pero en cuanto estuvo, por fin, operativo, me lancé de cabeza a «Archivo>Gestor de plugins…» y me encontré con esto:

¿¿¿¿Cómorrrrrrr???? ¿Qué hace ahí eso de «LogiOptions«? Bueno, ya me lo imaginaba, claro: se habría instalado con el programa «Logitech Options«. Pero en ningún momento dicho programa me había avisado de ello. Bueno, a ver: hoy en día, cuando uno instala un programa, tiene que aceptar todo tipo de «contratos», «acuerdos de licencia», «agreements» y parafernalia legaloide por el estilo, con lo que no puedo descartar al 100% que en algún rincón se hiciera mención a esto. Pero desde luego, se había instalado sin ningún aviso claro.

Sinceramente, aún tras comprobar que, efectivamente, yo tenía instalado ese plugin, seguía sin entenderlo. Me parece muy específico crear un plugin de Lightroom, teniendo en cuenta que es un ratón normal para ser usado principalmente con portátiles, y también teniendo en cuenta que, como dije antes, yo creo que no debería hacer falta un plugin para que el ratón funcione con Lightroom, en el caso hipotético de tener una configuración personalizada. Pero es que incluso aunque este ratón tuviera algún problema con nuestro revelador raw favorito, me sigue pareciendo raro que programen especialmente un plugin para un software tan concreto como Lightroom.

Pero en fin, lo que tenía claro es que iba a desactivar el plugin y probar qué pasaba, así que hice clic en «Desactivar» para desactivarlo, cerré Lightroom Classic y lo abrí de nuevo. Y, oh, sorpresa:

  • Ya no tardaba medio minuto en abrirse, ni se colgaba dos veces durante este proceso
  • Podía borrar fotos sin que apareciese el dichoso mensaje de error del valor nulo

¡La hostia, con perdón! ¡Así que todo esté tiempo me había estado fastidiando un plugin completamente inútil (al menos para mí), que se había instalado por la puerta de atrás sin decir ni pío!

Nota: El plugin LogiOptions no es la única causa posible de este problema. Un inicio lento de Lightroom puede tener mil causas, y lo mismo ocurre con el mensaje del «valor nulo» – aquí un ejemplo.

Una reflexión sobre esta historieta

No quiero terminar sin aprovechar esta historia para señalar una cosa: que la gente entienda que, cuando se trata de problemas técnicos, yo soy un usuario como cualquier otro. Y estoy tan perdido como ellos.

Menciono esto porque una parte considerable de los comentarios que recibo en el blog y en los vídeos, son de gente que sufre cuelgues de Photoshop/Lightroom, comportamientos anómalos de las herramientas y movidas técnicas por el estilo. Y me vienen a preguntar a mí como si yo fuera el servicio técnico de Adobe.

Página de asistencia técnica de Adobe. Por motivos que escapan a mi entendimiento, algunas personas me confunden sistemáticamente con esta web o uno de sus trabajadores.

Alguna vez he hecho la siguiente comparación para que la gente lo entienda: pedirme asistencia técnica de Photoshop/Lightroom a mí es el equivalente de llevar tu coche averiado a una autoescuela para que te lo arreglen. Son cosas distintas: en mi caso, una cosa es retocar y editar imágenes, en definitiva, saber usar esos programas. Y otra muy distinta es hacer que el software funcione bien o corregir errores relacionados con controladores, componentes de hardware o vete tú a saber qué.

Es cierto, pese a todo, que alguna idea tengo de los fallos más comunes, y alguna vez hasta sé la solución. Pero esos casos son la excepción: lo más normal es que no sea así, porque, como decía más arriba, cuando hablamos de problemas técnicos, yo no soy más que otro usuario, no un ingeniero ni un programador de las aplicaciones que comento en el blog o en los vídeos. Si a alguien le aparece un error extraño o simplemente le peta el programa, no tiene nada que ver con el terreno que yo toco, que es cómo usar esta clase de software, pero dando por hecho que funcionan correctamente.

Toda esta historia que he explicado aquí viene a demostrar justamente esto: en esta ocasión (y no es la primera), me encuentro con un problema técnico, y soy completamente incapaz de solucionarlo por mí mismo, como no sea investigando por mi cuenta o recurriendo al servicio de asistencia técnica del software que sea (no solo Adobe, sino Wacom, Topaz, Skylum, etc.). Lo cual, de hecho, nos lleva a una segunda reflexión – en mi caso, en cuanto tuve algo más concreto (el error del «valor nulo»), me lancé a google a investigar empleando el texto del error como criterio de búsqueda, y como veis, di con la solución rápidamente. En cambio, hay gente que parece sufrir de alergia a google por motivos que se me escapan. O será que les resulta más cómodo que yo haga búsquedas en google por ellos, no sé.

Un final feliz

En fin, el asunto es que por una vez, la cosa ha terminado bien. Digo «por una vez» porque lo más típico al dar con un fallo de estos es que no tenga una solución tan simple. Por poner dos ejemplos rápidos, en el módulo Mapa de Lightroom llevo meses sin poder arrastrar las fotos al mapa por culpa de un fallo relacionado con ciertas configuraciones de monitor. Y en Photoshop, las miniaturas de las capas me aparecen como «encogidas», de nuevo por un tema de configuración del monitor. Lo único que puedo hacer es esperar a que los señores de Adobe se pongan las pilas y arreglen este tipo de fallos.

Y eso ha sido todo por esta vez. Espero que estén teniendo ustedes un buen verano – vayan por la sombra.

 



Etiquetas: , , , , , , , , ,

Comments

  1. Hola Carlos, muy interesant el tema y gracias por compartir.
    Aprovecho para mandarte un saludo y buen verano.
    Saludos.

  2. Buenos días Carlos, como siempre muy buena explicación de los pasos a seguir en el caso de fallos en el software.

    Un saludo y buena luz.

  3. ¿Y no sería el taimado Mangaclick?

    Lo mismo se ha hecho un contratito extra, para pagar las vacaciones de verano, con Logitech y te ha estado metiendo el dedo en el ojo y tú sin saber quien era…

    Feliz Verano, Carlos, a pesar del virus ese.

  4. Buenas tardes Carlos. Termino de desactivar el «malvado» gestor de LogiOptions, media hora antes del plan que tenía para desinstalar mi catalogo con mas de siete mil fotos, desinstalar también Creative Cloud y el programa (LrC) , porque he tenido hasta este mismo momento los dos mismos problemas. El mensaje de error interno al eliminar fotos del catalogo y disco y la desesperante lentitud de arranque en una Workstation Hp con micro Xeon y un montón de cosas, SSD, 32 GB de RAM etc. que me costaron un dineral.
    Ahora funciona normalmente.
    Sinceramente! Muchas Gracias.

  5. Jajajaja, muy bueno y mejor comentado. Muchas gracias por dedicar tu tiempo también en aclarar estas supermovidas que hasta que no sabes la solución te angustian por algo que luego…es incomprensible, «un plug-in de un ratón». Hasta para cosas tan nimias tienen que meter «problemas».
    Ciertas cosas en tecnología tienen «elementos» que no nos sirven a nosotros… En fín, muchas gracias Carlos y buen verano Maestro!
    Por cierto, como hace un par de años dejé Lightroom, problema que me evité.

  6. Author

    Luis: Gracias, igualmente buen verano.

    Jordi: Muchas gracias, buena luz para ti también!

    Juan Sol: No me cabe duda de que el dichoso Mangalick está implicado en esto. Seguro que ha metido mano en Logitech a través de su red de esbirros infiltrados, para fastidiar todavía un poco más. ¡Algún día pagará por sus muchos y muy graves agravios! Feliz verano.

    Salvador: Gracias, buen resto de verano para ti también, saludos.

    Paco Márquez: Vaya! Me alegro mucho si esta información ha llegado a alguien que se viera en la misma situación, no contaba con ello pero sí albergaba esa pequeña esperanza, de modo que como digo, lo celebro. Muchas gracias por hacérmelo saber 🙂 Un saludo.

    Carlos Javier: Tal como dices, hasta lo más insignificante (en apariencia) puede acabar convirtiéndose en un dolor de cabeza. Cosas de la bendita tecnología… Gracias por tu comentario.

  7. Carlos ¿ como estas ?, vaya vaya lo que expones en esta info si que es para andar con muchísimo cuidado al instalar cualquier aplicación no solo lightroom, ahora en mas mas gracias a tí voy a «escrudiñar» cada aplicación que instale , gracias gracias, chau

  8. Yo no tengo ese plugin, pero me ha dado la idea de probar si desactivando los que no uso se notaba y, efectivamente, se nota y un montón. Yo soy novata en todo esto y los que he desactivado son el de Facebook (no sé que hace ahí) , Flickr (mi nivel no es para subir fotos ahí), HDR effex Pro 2 (lo utilizo desde Ps), Nikon Thether (yo tengo una Canon). Adobe Stock (para qué?)….. y la verdad se aprecia bastante porque últimamente cargaba muy lento. Ahora probaré a ver si en la operativa también lo aprecio. ¡Gracias Carlos!
    Si lees este post y quieres hacerme algún comentario interesante te lo agradeceré.

  9. Author

    Jose: Muchas gracias por tu comentario, un saludo.

    Ana: Hola, normalmente leo todos los comentarios, aunque no tengo mucho que añadir a lo que ya has comentado. Aunque en la captura de imagen que puse no se vea, en realidad yo también suelo desactivar esos otros plugins. El de Adobe Stock creo que sirve para publicar imágenes en la plataforma Adobe Stock, o sea, mandarlas directamente de Lightroom a Adobe Stock (que es una página de imágenes de stock).
    Gracias por tu comentario, un saludo.

  10. Excelente Carlos gracias por el artículo, me pasó el mismo problema, solo que en algún momento y buscando solucionar un problema con otra aplicación, desinstalé Logitech options y hasta ahora caigo en cuenta que eso me soluciona los problemas con LIghtroom, Si no fuera por tu blog, ni me enteró de lo que pasó.

    Un abrazo y saludos.

  11. Como siempre Carlos me dejas asombrado con tu buen hacer. Eres un crack. A mi me daba ese fallo pero ya me había acostumbrado a él. Tengo un ratón de esos que mencionas. Hoy mismo desinstalo el plugin de marras. Gracias por todo de nuevo. Impagable.

  12. Author

    Germán y Fernando, muchas gracias a ambos por vuestros comentarios.

    Viendo los comentarios de esta entrada, igual hemos de acabar creando una «Plataforma de Víctimas del Logitech Options», porque por lo visto está muy extendida esta puñetita del dichoso plugin salido de la nada! 😡
    Suerte que ya lo hemos descubierto y no nos podrá fastidiar más 😎

Leave a Comment

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.